[Journal] Panasonic Toughbook CF-19 MKII - 4G Support in Australia


Get out of my kitchen you flying ass
So ages ago after putting together the WINEdows distro, I got a CF19 MKII laptop just to use it with.
I later found out after receiving it that CF-19s support sim cards, I tried it out and nothing happened. Only to find out while researching I needed to install card for it. Sure enough I unscrewed the bottom caddy and found it was missing.
Apparently it was for these outdated Gobi 3000 cards or something.
Although I found some rumors on forums that some Sierra 4G cards worked with some of the later toughbooks, people generally referred to the Sierra Wireless MC7700. I did some digging and found for Australia/Telstra, I needed one with different frequencies and that didn't work. Unfortunately there were tonnes of those cards on ebay and were cheap.
Then I found a MC7304 card which had the correct frequencies for Telstra, although more of these frequency checker sites don't even mention Optus or Vodaphone for any of the cards. Odd but ok. But the shi*ty thing was these variants were more expensive.
Welp anyway I decided to import this card, I only found one in Israel and one in the UK. The Israel one was slightly cheaper so I bought that on ebay.

So I removed the battery like some obscure guide said, installed the card, then I set the first of the dip switches to ON like I found on this other weird forum and left the rest as OFF:

As for the wires, most of the images online with the card in place had a grey and green wire.
I had Black and Brown like in this picture. After googling which wire went where I found a thread from 2011 saying black is usually for the AUX popper. So I did that and just plugged the brown cable into the MAIN popper. Then left the GPS popper blank
(I guess it doesn't really matter too much)

Then I put the battery back in, popped in my spare Optus data sim, turned it on and went in the BIOS because I remember someone saying in one of the forums to go to some Optional Accessories menu or something and enable it there.
Instead I found a new option just amongst all the others called Enable WWAN.
I set that to enabled and saved.

After booting into WINEdows, I noticed there was a new sub area when I clicked the wifi icon on the taskbar.
"Mobile Broadband"
not enabled

...I couldn't figure out how to enable it, so when googling around I found this thread:

Which a guy says to do this command and install this program in a terminal:
sudo snap install modem-manager

So I did that, nothing happened really. So I restarted.
Still nothing.

Then I found this page:

Which is basically a graphics interface version that controls that same modem-manager thing I installed prior.
So ok, I install that with:
sudo apt-get install modem-manager-gui

After installing, I went to start>internet>modem manager gui.
Then it popped up with some setup windows which I quickly flicked through, now it shows a lot more detail and the actual Sierra 7304 card itself in the menu.
That's great, as at least now I know the computer can see the card itself. On the forums most people struggled to get non gobi cards to show past the bios or in the Windows device manager (and those guys on the forum were on later CF-19 models).

But as for why it wasn't connecting?
Eh it was just spitting out some message like "Modem is not ready for operation, please wait"
I waited for ages and got nothing

I went to the info tab and it was just saying the towers had "Unknown Status".
So I tried out my aldimobile sim from my phone instead. Popped it in and restarted again.

Now after booting up again I notice I can actually connect to a tower now through the regular wifi menu.
It asked for my country, my provider etc (I just went with telstra as I know aldimobile uses their towers). And sure enough, it worked just fine.
WHEW!!! However it's a shame the optus one ain't working, as I can have 5 sims with that one with the plan I have as aldimobile/telstra are expensive if you want another sim.

I went back to the Modem Manager GUI thing and found there were options for SMS messages and GPS.
Tested out the SMS and it worked, that's cool.
GPS did nothing which I expected, since I never plugged anything into it and probably need some dumb extra card for it anyway.

So yeah that was my adventure of getting 4G on the old af ToughBook CF-19 MKII.
I hope this becomes handy to someone out there, I imaging this process would work almost identically to Xubuntu/Ubuntu users.
Not sure how it works on Windows, but good luck anyway lol

Extra sources:
Whatever links I threw into the bottom of this thread